AP 2.0a Firmware Released!

Hi everyone, this has been a big one and many improvements have been made. The release notes have been posted here:

If you have any questions let us know, and as usual if you notice anything please create a new thread with the details.




Since I’ve updated it keeps dropping devices off the WiFi at random times.

Any ideas?

@Alta-MattH This is what keeps happening. Everything drops.
Screenshot 2023-12-20 at 18.54.10
Screenshot 2023-12-20 at 18.54.22

Yes Im seeing drops too, my graph seems to keep going but the device list is flashing with devices showing online then greyed out offline.

A lot of the ones that are dropping are Ring security camera’s and also an android phone. It also seems to be focused on my AP that’s in mesh mode, the devices connecting to that AP keep dropping and re-joining.

The other issues I was having with multicasting and all that seem to still be fixed.

@WhyAydan sorry to hear about the troubles. Did you reach out via chat? Matt and I have replicated this internally, and we’re digging into it further.

@MichaelMuni thanks for adding your report too!

I’m not going to be able to do this at scale, but I can help a some people revert if you need an immediate temporary fix, and there are technically options. Please reach out via DM or chat here on the forum.

Obviously this is very high priority for us; we’re on it.


It does not seem to be limited to the AP on mesh after looking a bit longer.
I downgraded mine back to the older build and then upgraded them back to 2.0a to see if there is any difference but still seeing the same.

I also set the SSID to only 2.4ghz to see if maybe they were bouncing back and forth off 2.4 and 5ghz between AP’s and that’s not it same devices are showing the same on 2.4ghz only.

I think both 2.0a and 1.1q-4 are both affected, but I haven’t actually cofirmed the latter yet. Not sure which you’re trying. I think the last good dev build may have been 1.1p-dbg2 (aka 1.1p-dirty), at least for one that includes multicast improvements.

1 Like

Same issue here

Same problem here. Is there any way to revert the firmware?

Just a single AP so not related to mesh. Kicks all devices off for about a minute. Intermittent.

1 Like

@user5 @user30

If you guys ping @Alta-MikeD a message he will then be able to drop the firmware version for you. Don’t think the downgrade path has been publicly released just yet.

Since the new firmware i have dropped connections and teams errors due to connection. Can i revert the firmware? If i am pitching a new customer on IT cases and my wifi disconnects… uhhh bad story. so please were can i revert the firmware because is was stable before,

for the devices that keep constantly dropping I’m seeing this error in the logs…

Yeah that’s what they found out and should be patching ASAP

1 Like

I’ve reached out to a few of you directly, but we believe we’ve resolved an issue that has occurred on a small percentage of sites, particularly those with shorter DHCP lease times. Please reach out to me if you’d like to try out the next release that addresses these issues, but it should be going out soon, either way.

My DHCP lease time is set to 24 hours.

It can definitely (and very likely will) still impact those with longer DHCP lease times, but it seems to cause more issues especially with those with shorter lease times. Those “No such r0 nor r1” error messages are innocuous when fast roaming is disabled, and will be removed in the next test release.

1 Like

Can you send me this firmware too?

Yes, I can. We’re preparing the updated build for release, and it should be out later today. I can upgrade you to 2.0b RC1 now if you’d like to see if it fixes your case, or if you want to wait for the final tag to be ready, it probably will be out later this afternoon.

So far it’s fixed it for other affected users who we’ve worked with.

For everyone looks like Alta have just pushed 2.0b!

Thanks to the Alta team for fixing this so promptly!


Came here because I was having dropped wifi issues over the last two days. When I logged into my Pro unit it showed 2.0a and had 2.0b ready to download/reboot.