My Sonos devices and AirPrint stopped working (but is working again now)

I thought I would share my experience with others in case anybody has come across this before and needs to resolve it, and so Alta Labs have some background in case it happens to someone else.

I have 4 Sonos devices that have been working happily with the Alta Labs AP6s since I bought them a few months back. That is until I added and removed a new SSID. None of my Sonos devices were wired.

I created a new SSID in addition to the existing ones. I added a time schedule to the new SSID. It was set as a standard network with one password which I set to be the same as my main SSID. After a short while I decided I wasn’t going to use the new SSID so I deleted it.

From that point onwards I found that the Sonos app on my iPhone wouldn’t connect to any of the Sonos devices, as if they were not on the network. However, I was able to ping each Sonos device individually so I knew that they had connectivity. I later found that AirPrint wasn’t connecting to my LaserJet from any iPhone devices. Mrs O wasn’t very impressed at all!

Following some AirPrint troubleshooting I found in another post on this forum I downloaded HE Tools and found that my printing nodes were not there under Bonjour Browser. Also Sonos devices were not listed.

I enabled IGMP Proxy, that didn’t help and I set all settings back to default. Still nothing. Multiple reboots of the switches and APs. Nothing worked. I then tested a spare Unifi AP in the same switch port and found that the Bonjour browser then started to show me the printer and Sonos nodes as you would expect.

Long story short, in order to get my AirPrint and Sonos to work again I had to create a new site, with SSIDs of the same name. I then ‘moved’ my 2 access points to the new site (through the portal). Bingo, the new site was working. AirPrint and Sonos were fine and back to normal. I delete my original site

I have no idea why this happened and why creating a new site worked. I checked every setting I could think of and made them all default nothing worked. It’s as if there are some hidden settings that were affected by me creating a new SSID, setting a schedule and then deleting it.

It has made me very reluctant to ‘tinker’ with any of the settings as it had been super stable again until then. I tend to know what I’m doing with networking kit and was surprised that it could be brought down by the actions I took.

Reboot might have done the trick.

It definitely has not been enough for me. I have had to do this type of full reset a lot of times to get multicast working again. So far the Alta team has not come to a conclusion as to what is going on.


Rebooting the APs and router was the first thing I tried.

Creating a new site was a last resort after extensive troubleshooting with no effect.

I’ve had no problems with Sonos up until that point and I suspect that the people experiencing ongoing Sonos issues might benefit from a new site but it is a bit of an extreme fix!

I did not have any issues with Sonos. The setting is on ‘standard’ in my case.

Are you using VLAN’s?


ok I think the people having issues are the ones using vlans. usefull info on tracking down the cause.

As an experiment I flattened my network yesterday (temporarily no VLANs). So far everything is smooth as can be and no hiccups with airplay, AirPrint, multicast. I will add VLANs back today without any firewall restrictions between them and see if things stay stable as well. Hopefully we can narrow down exactly WHERE things finally fall apart.

1 Like

I’m trying my hardest to break my network :slight_smile:

What switch/router are you running?

I’m using a UDR as router connected to an Alta 8 port switch. I can’t really work out if it’s an AP problem or the switch

I’ve got everything running through VLAN 1 now but I did create a cheeky VLan 3 a day or two ago and connected my iPhone to it. Now switched back to the default network and AirPrint stopped again.

Sonos is still fine this time .

On your UDR is Multicast DNS and IGMP Snooping enabled for both of your VLANs?

UDM Pro. UniFi 24-POE switch. Multicast DNS is on. IGMP Snooping is not enabled.

I’m currently using a Firewalla Gold rounter and on their site they suggest if you have a managed switch segmenting vlans to DISABLE mDNS snooping and MLD snooping on the managed switch.

I have your exact setup. Turning IGMP snooping on along with Multicast DNS helped as well as enabling BSS Translation, Fast Roaming and IGMP Proxy on the AP6-Pro.

I also noticed an odd issue with the Unifi 24-POE switch where it kept enabling Storm Control at 100 pkts/s on the port the AP was on. Setting the advanced settings to manual and disabling Storm Control was a big help as well.

Hi JRosen. I had all of that enabled except for IGMP Snooping. In the past with other APs that has caused nothing but problems. It’s worth a try though. I have that enabled now and will see in the next few hours if it helps or not.

Isn’t that weird about the storm control? I noticed that early on as well and had that manually set.

:sleepy: sadly, I’ve had to revert back to my old orbi access points until they can get this fixed.
Season 2 Smh GIF by The Lonely Island

I am very close to having to do the same.