Latest Firmware 2.0e - return of AirPrint and Sonos problems

For a while I’ve had no problems with AirPrint or Sonos. This all changed for the worse since installing 2.0e.

My Sonos sub seems to randomly fail to obtain DHCP IP address. When it does - it shows in the Sonos app - but doesn’t appear in the list of devices (it shows as a greyed out line without an ip address).

My HP printer has dropped off AirPrint again and can’t see it in my network tools app under the bonjour browser.

I suspect that this latest firmware has reverted the work that was done to fix this.

My Meross Garage opener also dropped off the network yesterday - although is working again now since a restart of the devices. My whole Alta system has become generally unreliable again. I hope that there will be a long term solution to these problems. In my opinion 2.0a or b was more stable.



I can see my AirPrint device connected to the AP6-Pro with the assigned IP but it is not available from the network.


Are you using an Alta Labs switch - I have issues with devices connected to my S8 POE not showing but everything else shows up, all the other devices are connected to Alta Labs AP 6 Pros running 2.0e firmware, these are then connected to an Aruba switch.

I did have an issue when the site set to Large that things showed up and then disappeared randomly but moving back to Standard seems to have sorted that out - have you tried that?

Hi user19

I did wonder if it could be switch related but different versions of AP firmware have fixed the issues without any change to switch firmware or setup so I came to the conclusion it wasn’t the switch.

Also when I did connect a Unifi AP to the Alta switch things started working again. .

@oakserver can you describe your network setup? Are you using multiple VLANs & SSIDs/PSKs?

My current setup is as follows.

I have 2 main SSIDs.

  1. my main SSID has 2 passwords. A normal and IOT network. Default VLAN was set to 1 but I’ve just blanked that value to see if it makes any difference.

  2. an additional IoT SSID for iot devices which is set to VLAN 10.

My Sonos and printer devices connect to the main SSID with standard password. These device are causing me issues.

My Meross garage openers connect to main SSID with iot password. The openers are causing me issues.

My other devices connected to IoT SSID with vlan 10 are all functioning well.

I should add that following a tweak by @Alta-Jeff the AirPrint is now working well but the Sonos and Meross openers (hardware v4) are still not.

I think Jeff is on to something and hopefully on the right track to resolving it.

I’ve got the same issue here. Airprint shows, but when sending a document the printer makes a noise then stops and i get a failed to print message.

Printing on the same vlan (wired) works.

Unifi switch- Nothing changed apart from update.

@user16 When printing works on wired, is that when you printer is wired, or the PC is wired?

I’ve managed to get around the Sonos problems by hard wiring one of my speakers to the network. This speaker then provides a dedicated wifi network to other Sonos speakers. Only problem with that is one of my Sonos speakers is too far away from the master Sonos speaker and can’t get wifi signal. This is therefore this is only a short term solution,

AirPrint - is behaving itself at the moment, but that is at the expense of loss of connectivity to my Meross Garage Door openers. It a situation I can’t really put up with for too long as Mrs Oakserver is increasingly aware that things aren’t working around the house.

If the AP6 and AP6 Pro continue to be incompatible with my key devices such as Sonos speakers and AirPrint on an HP printer, then I can’t really justify its continued use. I’m reverting to my Unifi setup for now but will keep an eye on the firmware updates to see if things improve. Fingers crossed they do.

I too gave up and reverted to my Aruba setup.

@CarlH Can we get more information on your setup? Which specific issues were you having? We’d love to help understand and fix your issue.

I am also having this issue. Although we only have 3 of the 8 installed.

network is
Pfsense router
Aruba instant on 1930 switch (local mode)
untagged lan is mgmt where the switch and AP’s live
there is no wifi for untagged vlan 1 traffic
vlan 75 is “house lan” where our wifi is connected.

I seem to have the same discovery issues. Cant see some sonos until the AP is rebooted. This also resolves discovery for a unified remote to a mini pc for displays in the theater.

Similar issues with Sonos although I did not investigate much sorry. I have a single SSID and password nothing complicated - it was all working fine on the 1.x software but been problematic since 2.x was released so just swapped back to Aruba and all was fine again.

I am having a similar issue - sadly i cannot revert back as i sold the Aruba APs and went all in on the AP6 pros and now have them fitted to the ceiling etc.

I have an Openwrt router running on an X86 box, I have also swapped this out with the standard BT router and i still see issues with Airplay and airprint.

I have a flat network although i have seperate ssids for IoT / guest / standard but i am going to put them all on one later to help see if this is part of the issue.

When using wifi from Alta it shows some options…

if i switch to the BT router and use it’s Wi-Fi it shows more options:

I’ve reverted to 3 x U6+ access points but still using the Alta 8 port switch to provide POE. I do have one Vlan and all my Sonos and HP is working.

I can categorically say it’s related to the Alta APs and not the switch

I have had some success with switching off Fast Roaming - it appears to make more show up when connected to the Alta AP although it seemed to work before 2.0e firmware with it enabled.

Has anyone else tried this or did you already have it unticked?

I’ve always had fast roaming unticked as that seems to cause even more problems with IOT devices. In fairness it causes issues with other brands of AP too not just Alta Labs.

Unfortunately, things are getting worse for me too. After initially only having problems with the Elgato Keylight, I can no longer connect to Sonos since the 2.0e update.
Just in this moment two Google Nest Audios have lost the connection. After restarting the Nest Audios at least one was able to reconnect… For the other one I also had to restart the access point.

Yeah here too. I’m being annoyed by the Sonos problems. I’m sorry to say, but I’ve bought the Unifi AP 6 + back and guess what, everything is working properly.

1 Like