Issue with roaming

Hi,

at home i have a setup with four AP6 (2 normal + 2 pro) and experience dropping connections when moving around being on FaceTime or WiFi Call with iOS devices with current updates.

There are four SSIDs (no AltaPass) and the one i have this behaviour with has no limitations in speed or other things. My settings here a pretty out of the box. I wanted to ask if i can improve something? The house is built with solid brick, not too big and the APs are spread around three floors so they overlap.

Thanks!

I had the same issue and disabled fast roaming and BBS transition, no more issues.

1 Like

For some reason the setting that causes the most problems is fast roaming.

I’ve not had problems with BSS transition though - I usually keep those enabled.

You mention that there are multiple APs spread over multiple floors with overlap, which is ideal when you want to create a mobile environment. Have you measured or mapped the signal? Have you customized any of the radio settings? If not, that likely would be an area to find improvement, to some degree at least.

Does it work better in some areas compared to others? Or does it seem to work well for some amount of time, and then it becomes less reliable?

Are there any noticeable symptoms other than a call dropping? Do you know if the phone appears to drop to cellular during time of issue?

Apple offers a rather useful Wi-Fi debugging profile which may help. You can get the instructions and profile from HERE, it’s free, you just need to login with your Apple ID. Would it be possible to load that and then share the logs and time of issue after?

Basically you would want to install the profile, use the device as normal, and when the issue occurs, note the current time, then save the debug logs as per the instructions. After that they need to be retrieved. The PDF instructions are clear, but not all steps need to be completed (like I don’t need a screenshot or sysdiagnose output, I should be okay with just the contents of the Wi-Fi directory).

1 Like

Hi,

I will test the suggestions this and tomorrow evening and will post the results.
The coverage is good and otherwise i don’t have any problems. Only the roaming thing popped up these days.

Will keep you posted. Thank you!

Sounds good, thanks in advance! Please do let me know if there are other visible/noticeable symptoms after your testing/information gathering.

I’m glad to hear that coverage appears to be sufficient. While overlap is desirable, too much signal can be almost as bad as not enough. Cell design is more nuanced when creating a mobility domain, at least if you want it to work as intended. So if no customizations have been made to the radio settings, then there like is room for improvement here. Will it solve what you’re seeing? Not necessarily, but it could improve it to some extent.

Many client STAs have RSSI thresholds that need to be hit before the device will really will want to roam, often in the -70 to -75 range. Regardless of what roaming assistance options are enabled, they’re just suggestions; it’s still up to the client STA to make decisions based upon the data it’s provided, and the client can make bad decisions.

When you say popped up these days, does that mean it was working fine or better for some amount of time before it stopped? And if it was working fine or better, was there any other notable differences?

Just to be clear, I’m not saying there isn’t a problem firmware side. I’m interested to help regardless of what the issue is. I’ll re-enable FT on my home network right after I submit this reply to try and replicate issues here too. Unfortunately my Apple devices are on the dev beta track, but usually that isn’t an issue.

Thank you very much for your comprehensive answer and your time!

The comment regarding this thing popping up now is because i don’t call very much FaceTime or WhatsApp at home while walking around and it happened then… :wink:
So nothing that worked at a time better and now not…

What i did yesterday is disable FastRoaming - walking around the whole compound and FaceTime with my son i had only (very) short interruptions when the connection switched from AP to AP.
That would be ok for sure.
With FastRoaming enabled the interruptions are definitely longer…

Disabling BBS transition gave me interruption free facetime

I’m also seeing the disconnects instead of roaming with my 2x AP6 Pro and both iOS and Windows laptops. It used to roam without a disconnect, but it’s disconnecting now, and even seems to disconnect if the client switches from 2G to 5G instead of that being a seamless switch.

1 Like

With BSS disabled the interruptions are getting more. The setup with BSS enabled and Fast Roaming disabled is the the best for me so far.

But like @Alta-MikeD suggested i want to look into this profile thing on iOS. Did not have the time till now

1 Like

One thing that I really like about the profile is that it can make it easier to visual the device roaming, which is helpful when tuning power levels, amongst other things.

Thanks @benmott and @user50 for also chiming in. Knowing it was working, or at least working better before, and then it isn’t now is a very useful data point.

So circling back, FT seems to work sometimes for me, but it doesn’t always work for me. It seems to go in and out at varying frequencies, and then possibly trigger other issue(s) when it gets into this state. It typically self-recovers, but I definitely wouldn’t want to rely on it in its current state.

The most obvious symptom I see is that my phone won’t roam to or from certain AP(s), so it’ll have poor signal which would make dropped calls much more likely (to guaranteed). If you check the on-device syslog, it’ll most likely loop about missing PMK-R1 (i.e. grep R1 /var/log/messages via shell on one of the APs would give you lines with that).

Below is an example log entry that would be visible on the AP(s) it’s trying to roam to (so you may need to check multiple):

Apr 27 13:16:16 172.20.0.6 hostapd: FT: No PMK-R1 available in local cache for the requested PMKR1Name

Do you see times where you think it’s not roaming as expected (i.e. when it’s dropping calls)? To me, it’s pretty obvious. The Diagnostics page can be great for that, at least when using iOS devices. There are a couple commands we can run during time of issue, if you want, and we can confirm if you’re seeing the same issue. Although, if you have hits for the logs above, then that probably is good enough form of confirmation.

You can Shift+Click on the name of the Alta Labs device from web management (like the actual text name of the Alta device) and it’ll open a web terminal where you can paste the above command. Ideally you’d run it on each AP that you think it should be connecting to, and then copy the content to a text file, or at least some of it.

As it stands, I would suggest disabling Fast Roaming for the near term, but it would be great to confirm that we’re seeing the same issue or not if possible before, just in case you’re hitting some other issue (although it’s more likely to be the same). Hopefully the above was clear enough, but happy to help clarify or expand on anything if needed.

We’ve just released firmware 2.0p which brings improvements for Fast Roaming. I’ve been running a test build that includes the same changes for a several days successfully.

Please do let us know how things work in your environments too, whether it’s improved, worse, etc. Thanks!

1 Like

Hi,

first of all i am very sorry to reply only now - but i was very tied up with work the last weeks and i could only test some.
For me, the solution with the deactivation of Fast Roaming was the best. Day before yesterday i switched it on again with 2.0p installes, but i got freezes here again.

So until i can get more time to play with the things more i will turn off Fast Roaming.

Thank you!

1 Like

Hey @Alta-MikeD!
Thanks for checking in about this. Sorry for the lateness; was out of town. Now that I’m back, I have been experimenting on the latest firmware (2.0p) and am still seeing some issues with roaming. When I checked the logs with that command, I am seeing that exact message (No PMK-R1 available in local cache for the requested PMKR1Name) several times over a few seconds when the device is in the ‘roaming’ zone between the access points. This causes the audio to drop or totally disconnect the call on our iPhones which happened today and yesterday when testing.

1 Like

Hoping we can get some traction on this on again. I am in the same boat that fast roaming has to be off or roaming does not work at all. 2.0p and 2.0q seem to have actually made it worse.

1 Like

@rutman286 we have been investigating that, but it’s difficult to reproduce.
@Alta-MikeD has a bit more info on this :slight_smile:

1 Like

I’m happy to help reproduce it and send you whatever kinds of logs / captures you want. I can’t reproduce NOT having a problem when fast roaming is turned on.

Hi
I’m just curious if the WiFi calling issue has been resolved. My client has zero cell service in his home and heavily relies on wifi calling. All residents are iPhone users.
The Luxul system I installed one year ago continues to fail. I hope this solution of replacing half the APs with ALTA will work.

If you are trying to fix WiFi calling, all APs absolutely MUST be the same. They need to be very well tuned as well, with enough overlap for fast roaming to work properly. I am not having any issues with WiFi calling anymore, but it took moving APs to different areas, and a lot of fine tuning to get it working reliably.