IoT Devices On The "Large" Network Type

When i setup my network i used the same SSID and password pretty much every device reconnected by itself as usual. However i have a few brands of smart plugs that show they are connected but for some reason aren’t getting an IP address? Any idea why that would be?

Update it was the WPA3 option. I had it set to on and for some reason the plugs didn’t get an IP. Didn’t have it set to required but it still caused an issue.

Good troubleshooting and good find Techout! I have found WPA3 to be extremely unreliable no matter what vendor’s APs I am using.

1 Like

Weird that it was set to on and not required yet devices that weren’t working with it just flat out didn’t work.

Ok update again they are showing IPs now but still not working.

Did a full restart. UDM Pro, Switch, APs everything full power down. I now see all the plugs and their names on devices and they have IP yet still no internet it seems.

Any chance you might be running into this weirdness I ran into?

I’m not using a UniFi switch. It’s just an unmanaged POE+ switch connected to my UDM Pro.

Are you comfortable sharing your SSID details for a second look?

Just checked the port settings on my UDM Pro and none of the storm control options are enabled.

Share the controller?

One plug just came online let me try the rest. One came back on it’s own the others still aren’t responding. They are showing normally in the controller now though.

Forgive me for the silly question but have you given the smart plugs a good power cycle after the WPA3 and AP changes? Those smart plugs are ridiculously finicky in my experience.

Yup i brought one inside with me lol and have done that a few times. I did a full rack reboot as well just so everything was forced to reconnect.

You could try enabling lower data rates on the 2GHz radio. Currently the default minimum rate 12Mbps, and some IoT devices may have issues without having lower rates enabled, especially if they’re towards the edge of the cell. It’s easy to revert if it doesn’t help.

Go to Settings, select WiFi if it’s not already selected, choose the SSID the smart plugs connect to, click Advanced Settings, scroll to the bottom, choose Auto (2GHz…), and select Manual, slide it all the way to the left, choose Save

Cut it in half will report back. Thanks

Would using the large network type over small/standard have any effect on this?

It definitely could. I would strongly recommend Standard to start with. There is filtering in place for the other networks that can cause communication problems depending on the protocol

There’s a great writeup about it here: Different Network Types :

I figured that but they are just WiFi plugs. The control is web based not local device traffic.

Try the following.

  • Go to where you set the SSID, password(s), etc
  • Click Advanced Settings
  • Scroll all the way down to the bottom
  • Set the 2.4GHz minimum rate to 2000kbps
  • Save

Will they connect after that?

They showed connected on the devices page before that but I did lower it and will test more today.