HomeKit, IoT and AirPrint issues

Hi there,
I switched from 4x TP-Link OmadaEAP 245 (+ local OC200) to 3x AP6-Pro Alta Labs. So far, the wifi is better and stable except I can’t print anymore and I am experiencing a lot of issues with my IoT and HomeKit.

Basic setup, 1 SSID, 1 VLAN. 1 AP6-Pro wire connected to my router (Firewala purple) and the 2 other AP6-Pro are meshed to the wired one.

Airprint: small HP envy that is not visible to my devices except if I’m disabling the fast roaming on the SSID.

IoT/HomeKit: A lot of devices are disconnected or not correctly connected. HomeKit is unreliable most of the time.

I can see all devices, printer, IoT, etc. in the Alta management console though.

I haven’t had this issue this the Omada. Just a bad wifi :slight_smile:

Thanks for your help


I’ve got similar setup, firewalla gold and 4 AP6-Pro’s. They are aware if this issue and had me try a debug firmware which seemed to fix the issue for about 24 hours. They are actively working on this and told me they will have a new firmware for me to test in the coming days.

1 Like

Great to hear!

As long as I can revert back to the old firmware, I’m ok to beta test a new one if it helps.

Thanks team!

yeah I reverted mine back after trying it.

This problem with AirPrint and HomeKit is becoming a bit of a pain in my home and is causing family tension. I can only hold out so long before I have to switch back to my Unifi AP’s.

I’ve had all sorts of printing issues. Some devices can print, some can’t. I’ve had problems with my Sonos - although that’s been behaving itself recently. I’m not at all happy at the moment and can’t really recommend Alta Labs equipment if the basics don’t work properly

Sorry to hear. This issue is definitely top priority for us. Have you tried or are you interested in trying an updated firmware? . I know you had commented in at least another thread about this, but beyond that I don’t know.

Please let me know. Thanks!

Welcome to the Alta community!

Based on your description I can’t say for certain that this updated firmware would fix all of your issues, but it may help with a majority.

If you’d like to try it then I would need to be invited to your site temporarily to initiate the upgrade. I would let you know once done and you could remove me after (or I can remove myself, whichever your preference). Ideally you would also turn off automatic upgrades (temporarily), but you could switch back at any time, if needed. Please let me know.

There is a new build ready as of this afternoon, if you’re interested in trying it. I’m not sure if you’ve already been contacted yet, so wanted to mention that. Please let me know if you want to try it and I can help get your devices upgraded.

I have 2pros and use HomeKit and printers as well. If you would like another tester I can test.

1 Like

Hey Mike,
Jeff contacted me and deployed the debug firmware and it’s way better! hopefully it will continue to work and not fail again. I will keep you posted!
Great job guys! :slight_smile:

1 Like

Perfect! Sounds good, thank you!

v2.0a is now released. Keep us updated on how it’s going!

I think v2.0a is causing an issue with some of my smart plugs. Starting this morning they are connecting to and disconnecting from my APs every few seconds. My newest ones seem to fine, but all others exhibit this behavior.

Hi @SpeedyWombat29 any chance you can invite me to your site so I can take a look at the logs? matt@alta.inc

Just sent the invite. Thanks for looking into it.

Taking a look now… I’ll report back soon

Hi Alta team,
Still with the debug firmware. No more issues with my IoT but the printer (Airprint) worked for a couple of hours yesterday evening but stopped working again. Same workaround, I need to disable the fast roaming to get this device worked.

I was just testing my HP printer this morning, and even hard-wired it doesn’t work unless I press the power button. Can you see if this works for you? (The printer itself, weirdly goes into power save mode)

Hi Matt, oh boy… Save the planet they said! the power save mode looks like the culprit here… I pressed the power button to wake it up and after a couple of minutes, the printer is back.
There’s no way to disable the power saving mode unfortunately.

1 Like

I’m still seeing the same behavior as yesterday. I also noticed this morning that several IOT devices show as connected to the APs and have an IP address, but they show as offline on my Firewalla. The AP shows live traffic, but my Firewalla doesn’t show anything.