TX/RX Rate for clients not displaying data

Only use web, not app. TX/RX Rate values sometimes show, most times not. When not there, None/None shows.

Have tried different browsers, different computers, clearing caches, new user profile on computer, Windows & Mac computers. Same behaviors seen in all scenarios.

Have tried various combinations of configurations within SSID, for APs tried various combinations of power/channels…same symptom no matter what. Single AP broadcasting or multiple, same symptom as well.

Latest firmware on APs (2.0e). Only have AP6 Pro model.

What would cause this behavior?

That’s a new one. Can you share a screenshot, please?

I just checked mine and the only times I see “None/None” is:

  1. It’s a client connected to a switch (wired)
  2. It’s a wireless client that’s currently offline

But I assume neither of these are applicable to your scenario.

I see this a lot with my IoT devices that only really talk when I have their corresponding smart app open and am asking for data. My air cleaners for example.

The majority of the devices that are on Alta APs at this time will be Apple based devices. iPhones, iPads, AppleWatches, HomePod. They are all wireless and will not be physically connected to network. They are not offline.

Would it be possible to invite me to the site to see if I can replicate and, if so, grab logs?

I’ll send you a DM with the email address to invite.

Sent invite.

Small update: I’m seeing the same thing on my end on your site. I only have 2 Apple devices on my network, they’re not showing the None/None for rates. I inquired with some other Alta people, they’re also getting valid rates. I’m waiting on a developer to respond to me internally. I just wanted to drop an update so you knew I didn’t forget about you.

FYI…this has been occurring off and on for some time (along with client name recognition being sporadic as well). Can’t pinpoint a time frame of when though. I’ve deleted ssids and forgot the WiFi network on client devices in the past to see if there was a relation between those actions and couldn’t see one.

I have lots of apple kit - all have some activity unless offline :

Hopefully, they will be able to help you get your issue resolved swiftly.

@Alta-Matt_v2 @Alta-Jeff

FYI…over the weekend, I enabled a couple of combo (2.4/5) SSIDs. The initial SSID I reported the issue with was only 5G and should have been just Apple devices. Once the other devices (various vendors) started connecting to the Alta APs, some (but not all) of the 2.4 devices are showing the TX/RX values (seems to be just channel 1 that do not show values for some odd reason), but still any of the 5G based clients will not show the TX/RX values.

@Alta-Matt_v2 @Alta-Jeff

Do you need to still have access to my site? Is there more data you are needing from this end?

I’m seeing messages like this in syslog for the APs:

[2024/01/23 07:28:26:2862] N: JSON: {“reqStats”:{“start”:1706016445,“stop”:1706016506,“period”:“seconds”,“clientId”:“ifUjFZYZXk8MQelqKzmL”}}

[2024/01/23 07:28:25:8977] N: JSON: {“stats”:120}

What do these mean? The start/stop values are always equaling a difference of 61. Is that a timer value of some kind?

Nothing more needed at this time. @Alta-Jeff is looking for indicators as to why your rates are reporting this way seemingly for just you.

Those log entries are a heartbeat/stats reporting combination.

@Alta-Matt_v2 @Alta-Jeff

Can someone provide details on how the Tx/Rx data is being sent to the Alta portal from the device?

I started from scratch. Deleted existing SSIDs, deleted site, created new site, created SSIDs again. Same issues.

I started from scratch even further. Deleted existing SSIDs, deleted site, deleted account, created new account, created new site, created SSIDs, added APs.

Above with the same issues each time. No Tx/Rx data flowing through.

Then I reset one of the APs (pressing reset button), re-adding to site, created completely different SSID, assigned to that freshly reset AP, connected device to that new SSID, same issue. No Tx/Rx data.

Currently, I’ve moved the wireless workloads back over to Unifi APs until this issue can get worked out. Yes, they report the Tx/Rx data correctly for clients.

@carrottspc We aren’t able to reproduce this in-house, which is why we need to work directly with you and anyone that can reproduce this. From what we’re seeing though, this is purely cosmetic. Are you seeing any actual connectivity issues on your network?
If you want to see what is getting sent from the APs, you can ssh to them, and run “rcstats-mon” to see the raw JSON data.

@Alta-Jeff

Is there a way to downgrade AP firmware? I know others have asked this as well. Even from SSH, a client connected shows no data rates.

TxRx Example SSH to AP

To answer your other question, no there isn’t connectivity issues. But the indicator of that one thing not working could also lead to other things not working as expected.

@carrottspc The TX/RX rate is simply read from the wireless driver, and in your specific case, is obviously incorrect. We will fix the issue, but please understand that this is purely cosmetic.

If you’d like to try a previous release, please reach out to support and they can downgrade for regression testing.