Sonos not working

anyone else having any issues with Sonos speakers no longer working with this last update? Everything was working fine and one of these last updates killed it. I’ve factory reset the Sonos speakers and setup them back up. They get an IP but then just disappear off the network.

Not sure where to look as I’m still new to the Alta world.

Nevermind… I got it working. I had to change the network type from standard to large back to standard and it started working fine. Weird.

I have a Sonos ARC, Sonos Sub, a Sonos One, and a Sonos Play 1.

I noted that initially they’ve been a bit temperamental with the Alta Labs AP especially when I had one AP6 and one Unifi 6+ on the same network broadcasting the Same SSID with same settings. Since I now have solely Alta APs things have settled down. The lasted update (O) seems to be working fine with my Sonos devices - which may I add none of them are wired.

I also noted that one of the Sonos speakers network type had changed from Standard to Internet only. Of course it didn’t like that at all and when I changed it back to standard it was fine. I don’t know how it changed to internet only. It must have been by human error.

Do you have any issues with the Sonos app? I’m still having constant issues with the app not being able to connect, keeps wanting me to update network settings.

When I had this issue it was when I found one of my play devices had changed to Internet. I would check all your devices in portal to ensure they are on standard network.

Also ensure your phone is connected to the standard network and not a restricted second SSID.

Sonos requires everything to be on the same standard network, not IOT and not Internet only networks.

When this is sorted for all Sonos devices and the mobile device that you are using to control the Sonos network it’s been stable at least for me.

Sonos are the Apple of the speaker world, glad to see ye got them working in the end.

Thanks for the suggestion. All the individual speakers Arc/SL/SL/Sub were set to default. when I changed them all to Standard problem has went away.

You cannot mix AP’s of different Vendors when using Sonos, Sonos is extremely finicky with that, it will see the SSID of your UI AP or Alta Labs AP as a rogue access point, this will never work at least not when using the Sonos App, you might get lucky if your house has less than 6 APs and you are utilizing AirPlay

Yes, Sonos has always been very finicky with anything even slightly out of the ordinary. It’s now fine though now I’ve eliminated rogue access points.

1 Like

If you’re having issues with the speakers showing up in the app, please try enabling the IGMP proxy, if you haven’t already.

I’ve also had significant improvement with reliability when I turn Fast Roaming on and BSS Transition off.

so when I enable Fast Roaming I lose a majority of my HomeKit devices and my AirPrint printer doesn’t function anymore. Any ideas on what to look at it?

The Fast Roaming side of things would be an additional troubleshooting step after enabling IGMP Proxy.

Did enabling IGMP Proxy not work for you @ccie17319 ?

Yeah enabling Proxy made everything a little more stable. I still lose the Sonos speaker on the app I would say once a week. When I enabled Fast Roaming Sonos was solid, but then HomeKit/Airprint go bonkers. The printer of all things causes the most headache for the family (the wife) so thats the priority :slight_smile:

For the roaming standards, the client(s) have to support the standard as well or connectivity issues are expected. It’s not a surprise to me that any IoT devices are missing any or all of the 3 roaming standards.

I would spin up a new network (Settings → Add New). Where you go from here is your call, but ultimately you’ll want a network without fast roaming enabled and a network with fast roaming enabled. I know how much fun it can be to switch SSID settings on IoT devices so your discretion as to what’s easier for you. I would venture to say the Sonos would probably be easier to change but also don’t have much experience with HomeKit.

I figured that would be the answer… thanks for the info, I’ll trudge down that path.

It’s a bit of an illogical situation now that I think about it. 3 out of my 8 Sonos devices came out before any of the 3 roaming standards were ratified, so you would think that the Sonos devices wouldn’t accept an SSID with any of the 3 standards enabled, but it’s quite the opposite.

On top of that, I have some IoT devices that you wouldn’t think would work with any of the roaming protocols, but they seem to associate without issue (except for this August Connect but I’m pretty sure that’s a slowly failing unit). Another option would be to see if the HomeKit stuff has any firmware updates available maybe? If so, they might get the roaming standard updates. It’s a stretch, but with 2 SSIDs, testing it is just a single toggle.