Some IoT devices have connectivity issues

I have noticed lately, not sure which I or J firmware, that some of my IoT devices are having connectivity issues. No settings were changed within the wifi networks. My IoT network is set to IoT mode on a VLAN.

I noticed specifically my Meross Smart Garage Door Openers dropping off the network the other day which continued today. Viewing from the dashboard, they connect, wait a few secs, disconnect, wait a few secs, and repeat continuously.

I tried changing a few settings like fast roam off, BSS Transition off, but neither helped. I then tried switching to a “Standard” network and that made a lot of my other IoT devices drop off (Google Home Mini) plus didn’t fix the issue. I then switched it to the “Large” network type and now everything seems happy.

Any idea what could be causing these issues?

Any chance some of those IoT devices are 2.4ghz? Make sure your SSID is set to “Standard” for now, and make the following change below. Set the Air-Time Efficiency for 2.4Ghz all the way down to 1000Kbps. This has helped a lot in my case.


Thanks for the recommendations! I ended up switching back to the IoT network type (since it’s for my IoT devices, plus just to try) and moving the 2.4 Air-Time Efficiency all the way down. Once the networks refreshed all the devices came back with no issues. Just for curiosity sake, I tried a few different air-time settings and that’s the only one that worked (1000kbps).

1 Like

Weirdly I don’t know why but I started having issues with the 1000kbps setting after a day or so. I changed the setting to 6000kbps and they seem to be more stable. I tried 5500 and they didn’t like that at all. If you have any more issues on your end try the 6000kbps as that has kept my devices on for the past two days. I also have updated the firmware to the latest one so unsure if that also helped or not…

Thanks @benmott keep us updated…