Scan Timed out message

Currently (firmware 1.1i) no WiFi scan works here. No Quick and no Full Scan. Does anyone have an idea what the problem is? The logfile in the console shows Error -22 on L77.
Could the firewall be interfering with communication here?

1 Like

I tried yesterday and it failed as well. Just tried again and was successful.

1 Like

I have no issues with this? works as it should on my site

1 Like

Hi @jtv-weimar, are you still having this issue? I was able to perform both quick and full scans with no issue.

This one might be tricky. I have had it fail now and then as well… is it perhaps related to a DFS channel event? Just a totally wild guess.

Hi @Alta-Stephen, yes the error is currently still.
Hi @rutman286, switching to non DFS channels did not change anything.
Update to 1.1j, the error still exists.

Could these logfile messages have something to do with it?

Sep 13 05:10:19 root: scanning…
Sep 13 05:10:19 root: scanning in 34 seconds (#2)…
Sep 13 05:10:53 root: scanning…
Sep 13 05:10:53 root: scanning in 10 seconds (#3)…
Sep 13 05:11:03 root: scanning…
Sep 13 05:11:03 root: scanning in 209 seconds (#4)…

For testing I installed two AP6-Pro in two networks.
No problems if the web browser is in the same LAN as the access point and no DFS scan is running.
If the web browser is in a different LAN there are problems.
In the screenshot my browser was in the network. The problems are only when accessing (NAT) the network.
Both networks are behind the same firewall.

1 Like

Thanks! I can replicate the error you’re seeing. It started when I was traversing the NAT, but I’m seeing it elsewhere now. This feature shouldn’t be dependent of what network you’re connected to. We’re investigating further.

EDIT: updated for accuracy

1 Like

So I’ve found one way to reproduce Error -22 on L77 100% of the time, and it does not involve NAT/external networks.

If I have 2 different SSIDs provisioned to 1 AP, and both SSIDs are set to Password security, and both SSIDs have a password that assigns the same VLAN ID, then I hit this 100% of the time. As soon as I change the ID (only on one AP, so they no longer match) or remove the second SSID, scanning always works. Tried various ways local and across NAT, and it didn’t seem to matter. That said, I’m not ruling out other existing method(s) to trigger this, I just haven’t hit them yet.

Found another bug with scanning where if I have 1 SSID using password, but have multiple passwords using the same VLAN ID (on this same/1 SSID), then it will never finish. This one doesn’t throw an error in the local syslog on the device, but it will throw the same scan timed out error in the management UI.

So a couple of bugs. I will keep testing other variations of this and will open tickets for each so we can get these resolved.

@Alta-MikeD very nice that the error can be reproduced.
My network does not use passwords but a VLAN. And because the migration to Alta Labs is not finished, there are still 25 old Wifi accesspoints (the ones with the U in the name) are still in the same VLAN. :frowning_face:

Can you please share the current configuration of your SSID(s) via chat or DM? I would like to see if I can replicate here too. Thanks in advance!