Roaming not seamless, experiencing drops

With first impression being realy good versus my old setup. Even getting rid of some weird quirks i was having, i can definitly say that i’m very satisfied so far except for this;

The one thing that i’m defintly noticing when walking around the property is that roaming with both laptops and phones is not “Seamless”. When on calls (Teams or other) i experience noticeable connection drops. The application has to re-connect and missing out for more than a couple of seconds.

As far as settings on my end; all the WiFi settings are on standard except for IGMP snooping enabled. As fast roaming isn’t a setting that i enabled as of known issues and incompatibilty with older/specific equipment i was wondering if anyone else is experiencing this as well.

I never had this specific issue with my old installation. With that installation fast roaming was disabled as well.

Greatly appreciate your feedback

Hi @Michael_NL thanks for the feedback!

I’m curious if you could create a new network with fast-roaming enabled and see if the roaming is seamless. You could have a separate network for the legacy devices that don’t support it.

Curious if this is an option?


Hi @Alta-MattH,

Thanks for reaching out.

I could (even) try to enable fast roaming on the current network. But as with other deployments i never used fast roaming to get the “normal” expected roaming experience where the hand-off should be seamless enough that video calls/connections in general won’t drop when roaming.

As 802.11r (fast Roaming) is known for it’s problems with older devices but as well with more modern iPhones/iPads as well i would rather not go down this rabbit hole.

I’m probably more curious if this isn’t a bug and enabling Fast Roaming is going to be a work around.

Kind regard,

Can you confirm that you have overlapping signal between both the APs?

You can check with Acrylic Wireless Analyzer to confirm.

1 Like

Hi @KimchiGUN,

Following up on your question to confirm the channels with the AP’s im running these tests with.

Channels are on the 5GHz: 36, 48 and on the 2.4 GHz 6 and 11.

As per your reqeust i downloaded Acrylic to confirm these settings.
Confirmd channels

Herewith both screenshots (1 from the controller and one from Acrylic)

1 Like

I was asking about signal overlap… do you have good enough signal between the APs.

@KimchiGUN reading is an art itself :upside_down_face:
I was reading “channel overlap”.

Then answering your question once more. Yes, There is enough signal overlap.

1 Like

@Michael_NL You will definitely want to enable fast roaming in order to have a seamless roaming experience. From what I’ve seen, when fast roaming is not enabled, devices seem to be more sticky to their current AP, even if the APs support 11k and 11v.

Thanks for listening in on this matter.

On the locations where I am experiencing these drops there is (enough) overlap. So it’s not that I’m walking (far) out of range from one AP to the other. I get the feeling that when my devices are switching that it takes longer then what I was experiencing with earlier installs with no fast roaming enabled.

What I did now is enabled fast roaming on the WiFi network and see if we are going to run into any issues and/or if the problem will be solved. Although as stated in my previous response I would have expected not to enable fast roaming.
If that’s the basic and only solution for seamless roaming with no issues than this could be on by default right?!

If you have other insight for these settings or the issue itself then your input is greatly appreciated.

As stated in my topic opening I’m very pleased so far with the AP’s. I have very good hopes and trust in the succes of Alta, and with more product upcoming and more development on the way i could see me and my customers moving from other vendors. Keep up the good work.

@Michael_NL You are absolutely right, but we are trying to strike a fair balance between old/buggy legacy devices and modern ones. We do plan to improve this, though, in upcoming firmware releases, to be able to enable fast roaming automatically and dynamically. For the time being, in most cases it’s safe to enable fast roaming, and a dynamic option will become the default setting once it is ready.


@KimchiGUN thanks for your feedback too, this Acrylic tool looks nice! I haven’t tried it yet, will check it out. :slight_smile:

1 Like