Possible inter-vlan routing issues

I have been using the AP6-Pro for a little over a week now and performance has been decent. I am noticing a few issues with either a VLAN bug or something getting in the way of routing. I have two VLANs setup. My default network (VLAN 1) is where my phones, computers and Apple TV/HomePods live and then the IOT network (VLAN 30).

  1. AirPrint Issues - Since I installed the AP, AirPrinting from VLAN 1 to VLAN 30 has been an issue. iOS devices can see the printer but the jobs either never start or take a long time to print. If the print is successful, the iOS device never gets the update from the printer to say it completed the job so the iOS device keeps trying to print the same document. If I move the phone or printer to the same VLAN it works. If I switch back to my Unifi U6-Pro it works across VLANs without issue.

I did testing over this past weekend. I tried updating firewall rules and saw successful traffic on port 631 between the printer and iOS device but it still wouldn’t print. I even enabled all traffic between the printer on VLAN 30 to VLAN 1 and it still wouldn’t print.

  1. HomeKit - Randomly I have issues with Siri requests and HomeKit devices losing connections to the HomePod’s. The other day I got home and asked Siri on a HomePod to open my blinds. It took a little to respond and then said it was taking too long to respond. Checking the Home app I noticed I had quite a few devices having issues connecting to HomeKit. Asking the HomePod an internet based question such as if it was going to rain yielded the same result. After waiting around 20 minutes the issue resolved itself and the Home app was able to see the devices on the IOT network again. One of the days it happened I just rebooted the AP and everything started working properly.

This morning the issue happened again at around 5:30am. I clicked on a scene in the Home app and it failed. I noticed multiple devices couldn’t be seen in the Home app. Then multiple devices lost connection with the AP. I knew it was the devices loosing connection because the Aqara Hub flashes blue when it loses connection to the AP. After a few minutes the devices were back online and seen by the Home app. Earlier in the day I got a message that all my Home Hubs were not responding which leads me to believe the AP dropped the devices as well.

@JRosen I’ll send you a direct message with a few questions, then we can follow back here in the thread…

@JRosen Could you ever solve this issue? I have the same issues with connections across vlans

The Alta team was able to fix my issues and those fixes have been applied in some of the recent updates. It’s not the best path for everyone but I also reset my UDM-Pro and added all of the settings back manually because we kept seeing some unexplained issues with DHCP. Also keeping all of the SSIDs on the Standard network type has helped as well.

1 Like

Unfortunately, I still have these issue. Currently I’ve found a workaround that works for me and assigned some devices to different network types with AltaPass. So I have a working setup for the time being. However, it would be good to solve my VLAN problems too. But the Alta team is already on it