Performance drop and disconnects after 1.1a update

Ran the 1.1a update and noticed performance dropped quite a bit and the AP is no longer stable. Tried rebooting multiple times but same issue continues to happen. Before the update the AP was averaging 300 down and 200-300 up. After the update my iPhone can’t make it through a speed test without disconnecting from the AP.

1 Like

@JRosen Sorry to hear, that is definitely not something we’ve seen in our testing. Are any of your APs mesh, by chance? What is the signal strength of the iPhone during the speed test?

I have a single AP6-Pro. All of my devices are disconnecting. iPhone has line of sight to the AP in the same room but it doesn’t stay connected to get a signal reading. I have reset the AP and still have experience the same issue.

Is there a way to roll the update back?

Unfortunately 1.1a seems to be having a very similar effect on my AP6. You could actually watch the number of devices cycle up and down in the iOS app or web interface. I tried rebooting a couple of times to no avail. None of my Wi-Fi 6 devices were able to stay on 5Ghz and would cycle back and forth to the 2.4 GHz channel. Speed tests from my iPhones, iPad and Mac were all well below normal 2.4 GHz speeds and nowhere near the previous 5Ghz speeds. I switched back to my old non-Alta AP until Friday when I can perhaps try a factory reset.

1 Like

The factory reset didn’t help me. Luckily I still have my UniFi AP plugged in so I’m going to power that back on to get everything stable until I can either roll back the update or Alta releases an updated firmware to hopefully fix this issue.

@Digitalguy @JRosen There is no way to downgrade the firmware, and the changes since the last release are minimal. All of our test sites continue to work great, so I’ll need to work with each of you directly. Can I DM each of you and gain access to your sites to obtain logs?

Somethings going on with the 5GHz radio…

Edit// after changing the channel width to 80 or 40 the SSID cease to even broadcast.

I know it is not helpful to those having problems, but maybe Alta can compare logs and see what’s up. I too have run the firmware update, and I am not having problems. I am only posting to offer, if you want logs to compare, let me know what to send you.

I have to say, not being able to roll back firmware is not well received. Please consider changing that as soon as possible. That makes for a potentially very bad user experience if a mistake is made. We are all human, it is absolutely possible to push out buggy firmware, and not allowing a roll back is asking for trouble.

@rutman286 We may consider the option to go back, but we will focus on the ability to opt out of updates, first, for those that wish to do so.

@JRosen @Digitalguy Thank you for your valuable feedback. Your issues should be resolved in the 1.1b firmware.


@Alta-Jeff Really appreciate the quick response and resolution. I moved the devices back to the AP6-Pro a little over an hour ago and everything seems to be stable and performance is back up to where it was before.


Installed the update this evening and all is good with the AP now. I just need to go up the ladder, take down my old AP and reinstall the Alta AP6. I’d do it tonight, but I don’t want anyone watch while I fight with your mounting clip. Thanks for the quick fix …

1 Like

This exactly describes my issues I have with one of my customers.

I installed 5 AP Pro’s in his house + garden + barn. Placement is on the top of the wall, same place as the previous provider AP’s where installed.
Customer is know complaining about disconnects. I did some test and it seems that when I am doing a speedtest my Iphone get disconnects a lot of the time. Kids are complaining too.
Customer has a lot of IPhone/Ipad/Macbook hardware and also 8 Sonos speakers. Firmware of APs is 1.1c

Any suggestion how to troubleshoot/fix this issue before replacing the AP’s or changing the whole setup ?

@Rinse If you want to, you can invite me to your site and I’ll take a look at your settings. I’ll send you my email in a DM.

@Rinse curious to see if the issue has been solved and what was done?

Issue looks to be present on one AP (of five present in the network)
So I made an extra SSID and left out that faulty AP.

One other thing I saw when logging in to an AP via SSH is that the AP does DNS interception. I know that this can give some issues. My customer is complaining about slow starts of new sessions which points out to some DNS timout.
Is it possible to disable the DNS interception with one switch/setting ?

Exactly what I am experiencing here.

We see dns-masq running on the AP’s.

@Alta: Could you please make a button in the GUI to switch this off? the DNS masq seems to cause trouble on some Apple devices over here, which degrades the user experience dramatically.

All these stuff is done on our gateways/firewalls, i only need the AP6 PRO’s perform Layer2 WiFi tasks :wink:

@Rinse @ArendB The AP generally does not perform DNS interception, unless you have enabled the hotspot. If you are not using the hotspot, I can confirm that the AP is leaving the packets untouched for the DNS server. I’m happy to look at any tcpdump packet dumps (and AP logs from /var/log/messages*) where you are seeing issues, though.

Thanks for the response.
I will try to get access to the AP that had issues (It is on a customer location so I need to have connectivity first).

But what about the Filtering option. If it’s not done via DNS/DOT/DOH , do you create firewall rules in hardware to block applications ? Could it be that some filtering rule was not cleaned up correctly in the AP ?