MAC filtering on AP6-Pro's - unable to enter MAC addresses into field

Hi Folks,

I am experiencing what seems to be a bug in the controller website for my AP6-Pro AP’s. Unless I am missing something as a prerequisite the MAC address filtering field does not allow text to enter any MAC addresses when enabling the allow list. This seems like a bug within the controller site. Is this a known issue?



Yes, I had the same issue and contacted Alta support last week. They know about it, but I never did hear back on an ETA on when it might be fixed. But I did find two workarounds for now:

  1. The easiest is to use their iOS app and that allows you to add the MAC addresses.

  2. If you don’t have access to an iOS device, and if you know how to alter HTML code, in a web browser you can right click on that text area box and select “inspect” which should popup a widow showing you the code. You can delete the disabled=“” attribute for that text area box and then it will allow you to enter text in that box. (I’ll try and attach a screenshot of it, but I’m not sure how/if this forum will display it.)

Another warning as well, DO NOT add any comments using the “#” symbol like it says you can. If you do then you’ll find your main purple “Save” button on the bottom of that page ALSO disabled in the future.

I’m baffled how this made it past any Q/A testing, but hopefully they’ll get it fixed soon.

Hi guys, this should be fixed in the recent releases. Can you confirm you’re on the latest firmware?

Hi Matt,

I’m on firmware 2.0g, but I don’t think this particular issue is on the AP devices themselves as the textarea box in question is on/through the cloud management portal. When I responded yesterday with a work-around for the OP the textarea box was still disabled. However, it now appears to be allowing text to be entered so something was fixed overnight or this morning. I will give it a test here in a bit and report back…


Alright, got it tested. Although you can now enter text into MAC filter allow/deny textarea box, it will ONLY handle MAC addresses, no comments:

1 - If you enter MAC addresses and comments as this, the purple “Save” button at the bottom becomes disabled:

xx:xx:xx:xx:xx:xx #Comment1
xx:xx:xx:xx:xx:xx #Comment2
xx:xx:xx:xx:xx:xx #Comment3

2 - If you move the comment to the front of the line, you can save it, but the AP will NOT interpret the MAC addresses correctly and the list won’t work:

#Comment1 xx:xx:xx:xx:xx:xx
#Comment2 xx:xx:xx:xx:xx:xx
#Comment3 xx:xx:xx:xx:xx:xx

3 - If you just enter only MAC addresses, then all works correctly:


So, basically no comments allowed.

Also of help is that the text entered in step #2 caused these log messages per MAC address:

Feb 12 19:20:08 OpenWrt daemon.err hostapd: 8y30apkbv4: Might kick xx:xx:xx:1d:93:c1 due to ACL reject (if not mesh)
Feb 12 19:20:08 OpenWrt hostapd: 8y30apkbv4: STA xx:xx:xx:1d:93:c1 IEEE 802.11: authenticated
Feb 12 19:20:08 OpenWrt hostapd: 8y30apkbv4: STA xx:xx:xx:1d:93:c1 IEEE 802.11: Not mesh station
Feb 12 19:20:08 OpenWrt hostapd: 8y30apkbv4: STA xx:xx:xx:1d:93:c1 IEEE 802.11: disassociated

All MAC adddresses and “hostapd” changed for privacy of course… Hope that helps!

While I’m not sure if this is the intended behavior (I have inquired and will follow up), you appear to be able to put comments on a newline like so:

# This is a test

I can also confirm this works for filtering.

1 Like

Just confirmed, this is the way comments are intended to be used. Only comment or MAC per line

1 Like

Can confirm all is working as expected now, thanks! (Although my brain went with the comment above the MAC. :slight_smile: )

#Comment Here


Is that one of those Northern hemisphere vs. Southern hemisphere things? :rofl: just kidding