IPv6 on Telus not working

Has anyone had any luck getting IPv6 working with telus?
I have it set to DHCP and PD size of 56 which I read it should be (but 64 or blank makes no difference.)

Has anyone else had any luck? Is there anything else I can try?

My output of cat /etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'eth3'
        option mtu '1500'

config interface 'wan'
        option ifname 'eth3'
        option metric '200'
        option dns_metric '200'
        option proto 'dhcp'
        option norelease '1'
        option ipaddr '##.##.##.##'
        option peerdns '0'
        option dns '1.1.1.1 1.0.0.1 2606:4700:4700::1111 2606:4700:4700::1001'
        option reqprefix '56'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth3'
        option norelease '1'
        option peerdns '0'

config device
        option name 'br-lan'
        option type 'bridge'
        option mtu '1500'
        option stp '0'
        option igmp_snooping '0'
        option ports 'eth2 eth1 eth0 eth5'
        option macaddr 'bc:b9:23:81:##:##'

config interface 'lan'
        option ifname 'br-lan'
        option proto 'static'
        option ipaddr '192.168.86.1/23'
        list ip6class 'wan6'
        option ip6assign '64'
        option multicast_querier '0'
        option igmp_snooping '0'
        option force_link '1'

config interface 'vpn0'
        option ifname 'ppp0'
        option proto 'none'
        option auto '1'

config interface 'vpn1'
        option ifname 'ppp1'
        option proto 'none'
        option auto '1'

config interface 'vpn2'
        option ifname 'ppp2'
        option proto 'none'
        option auto '1'

config interface 'vpn3'
        option ifname 'ppp3'
        option proto 'none'
        option auto '1'

config interface 'vpn4'
        option ifname 'ppp4'
        option proto 'none'
        option auto '1'

config interface 'vpn5'
        option ifname 'ppp5'
        option proto 'none'
        option auto '1'

config interface 'vpn6'
        option ifname 'ppp6'
        option proto 'none'
        option auto '1'

config interface 'vpn7'
        option ifname 'ppp7'
        option proto 'none'
        option auto '1'

config interface 'vpn8'
        option ifname 'ppp8'
        option proto 'none'
        option auto '1'

config interface 'vpn9'
        option ifname 'ppp9'
        option proto 'none'
        option auto '1'

config interface 'vpn10'
        option ifname 'ppp10'
        option proto 'none'
        option auto '1'

config interface 'vpn11'
        option ifname 'ppp11'
        option proto 'none'
        option auto '1'

config interface 'vpn12'
        option ifname 'ppp12'
        option proto 'none'
        option auto '1'

config interface 'vpn13'
        option ifname 'ppp13'
        option proto 'none'
        option auto '1'

config interface 'vpn14'
        option ifname 'ppp14'
        option proto 'none'
        option auto '1'

config interface 'vpn15'
        option ifname 'ppp15'
        option proto 'none'
        option auto '1'
ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth3",
        "data": {

        }
}

Edit 3:

ifconfig
br-lan    Link encap:Ethernet  HWaddr BC:B9:23:81:##:14##
          inet addr:192.168.86.1  Bcast:192.168.87.255  Mask:255.255.254.0
          inet6 addr: fe80::beb9:23ff:fe81:2514/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:155611577 errors:0 dropped:0 overruns:0 frame:0
          TX packets:617768647 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:39957707158 (37.2 GiB)  TX bytes:1054382576431 (981.9 GiB)

eth0      Link encap:Ethernet  HWaddr BC:B9:23:81:##:##
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:238933971 errors:0 dropped:0 overruns:0 frame:0
          TX packets:870322275 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:64278373470 (59.8 GiB)  TX bytes:1179516869695 (1.0 TiB)

eth1      Link encap:Ethernet  HWaddr BE:B9:23:82:##:##
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8421644 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23040117 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3047171979 (2.8 GiB)  TX bytes:23991225231 (22.3 GiB)
          Base address:0x4000 

eth2      Link encap:Ethernet  HWaddr BE:B9:23:83:##:##
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18585228 errors:5 dropped:8677 overruns:0 frame:5
          TX packets:98942297 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4526380389 (4.2 GiB)  TX bytes:108253786463 (100.8 GiB)
          Base address:0x8000 

eth3      Link encap:Ethernet  HWaddr BC:B9:23:81:##:##
          inet addr:75.156.107.27  Bcast:75.156.107.255  Mask:255.255.252.0
          inet6 addr: fe80::beb9:23ff:fe81:2515/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:981215730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:255918780 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1307193858567 (1.1 TiB)  TX bytes:67456386142 (62.8 GiB)
          Base address:0xc000 

eth5      Link encap:Ethernet  HWaddr BE:B9:23:84:##:##
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:482676 errors:0 dropped:0 overruns:0 frame:0
          TX packets:482676 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:55046437 (52.4 MiB)  TX bytes:55046437 (52.4 MiB)

Hmm ifconfig shows some devices with ipv6 possibly, some just are missing? But are those just local ipv6? Edit: Yes fe80 is local.

My current suspicion is that it is an ISP issue. I’ll phone them next week.

Sorry to hear about your issue. Unfortunately I do not have experience using IPv6 over Telus—I’m up in Canada, too, but I don’t have Telus available over the wire where I am. I’m wondering, can you try the following from shell on your Route10 please?

uci delete network.wan.reqprefix
uci set network.wan6.reqprefix='56'
uci commit network
/etc/init.d/network restart

The shell session may terminate, but once it restores, and/or after 10-15 seconds, please check ifstatus wan6.

If it’s not pulling and address, or not working on all VLANs it would be worth a reboot, in case, but we would need to make it persistent first. I don’t think it would be needed, but if we did have to go that route, if it’s still not working post-reboot, I would copy /var/log/messages (and messages.0 and/or .1 if present). There should be relevant logs for it trying and why it’s failing.

To make that persistent we need to create a post-cfg.sh in the /cfg on the Route10 (so /cfg/post-cfg.sh), that contains the above commands. There is both nano and vi. Or if you want to use your preferred text editor on a computer and transfer via scp you can, just remember to make sure your line endings are set to LF (line feed). Once the file is in place you’d then need to run chmod +x /cfg/post-cfg.sh to make it executable.

Please let me know if you have any questions about that, or if that helps or not. There might be something else to try, but I’d like to start here. If this works, I can help you make it persistent at least.

EDIT: major correction/addition (reboot requires post-cfg.sh.

After making your changes I am getting the same status:

~ # ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth3",
        "data": {

        }
}

Going through the logs I see:

Feb 19 12:40:14 OpenWrt daemon.warn dnsmasq-dhcp[11651]: no address range available for DHCPv6 request via br-lan

Though I can’t upload the entire files here.

I tried to get support from Telus, but they were … not helpful.

Can you please retry by adding one more option? Here is the full set of commands that you’d want to use (it’s okay if the others are still set, it won’t break anything, just in case they cleared):

uci delete network.wan.reqprefix
uci set network.wan6.reqprefix='56'
uci set network.wan6.reqaddress='try'
uci commit network
/etc/init.d/network restart

Are there any IPv6 or DHCPv6 log entries for wan6? Or just br-lan? Do you see the modifications if you check the wan6 interface in /etc/config/network?

Tried your new instructions without any change it seems.

Output of cat /etc/config/network

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth3'
        option norelease '1'
        option peerdns '0'
        option reqprefix '56'
        option reqaddress 'try'

There are no IPv6 or DHCPv6 entries for wan6.

Last entries after /etc/init.d/network restart is:

Feb 20 11:32:16 OpenWrt daemon.notice netifd: Interface 'wan6' has link connectivity 
Feb 20 11:32:16 OpenWrt daemon.notice netifd: Interface 'wan6' is setting up now