IoT Issues after 2.0b update

After the 2.0b update, my Meross smart outdoor plug and garage door opener connect and disconnect every couple of seconds. Fast roaming isn’t enabled on the SSIDs they are connected to and they were stable prior to 2.0a.

Hi @JRosen any chance I can get access to your network?
Just want to take a look at the logs…

Just sent the invite. I am home and can test different things if needed.

Thanks! Just got it…

I know this doesn’t help your situation but I have 2 x Meross Garage Door openers and a bunch of their switches and they are working fine for me at the moment with 2.0b.

I don’t have any VLANS at the moment and the openers are on my main SSID with an IOT password.

I had issues with my Meross Garage Door Openers in the past firmware. They kept blinking connected/disconnected. I have tried NUMEROUS settings and here is what I was successful with (your results may vary, but just putting this out there):

Put them on a NON-VLAN “STANDARD” network, Bypass Filter enabled.

Default network VLAN 1

NO features enabled except the BSS Transition.

Some others tried different air-time settings with success but I kept mine on auto.

I have had to create a dedicated password for my Meross items. I have other passwords on the same SSID doing different VLANS but I don’t think their devices can handle the VLANS for some reason. I have emailed Meross support but they don’t know really what’s happening.

The KEY is that you MUST remove the garage opener from the app, reset the device itself (push and hold the button for 5 seconds) and then add them again using the new dedicated password non-vlan standard network. This completely solved my issues.

I was having problems with the Meross Garage Door Openers and some Meross Smart Switchs and plugs so I just moved them all to the special network and now no more problems. Replicating those settings on the existing network didn’t work for some reason as they kept connecting/disconnecting, the devices MUST be reset and reconnected.

I am hesitant on doing a reset. I have another Meross plug I tried to add to wifi and it will not connect.

My issue is it has to be something with the AP firmware. Both the Meross plug and garage door opener were 100% working on pre-2.0 firmware with VLANs. Nothing else has changed on my network so in order to test this theory I disable the SSID on the Alta AP and brought up an old Unifi NanoHD. The minute the NanoHD had the SSID enabled, the garage door opener connected right away and showed up in the Apple Home app without any drops. I have also noticed that my HP printer keeps randomly losing connection as well.

Matt from Alta has been looking into it which I am very thankful for. Hopefully we can find a solution soon.

Hi guys, still looking into this … any chance you can join our discord server to troubleshoot real-time? I know it’s a holiday weekend, so no rush :slight_smile:

any update to this? I am thinking of going back to my old setup.

The Meross issue was due to the Meross devices ARPing for their own IP address, and then declining the IP address from the DHCP server. @user27 what specific issue are you seeing?

goes in and out of wifi. Doesn’t connect.

@user27 Which specific devices are disconnecting? Do you have any non-native VLANs utilitied? Can I DM you to get an invite to the site?

Merry Christmas guys. I’m running 2.0b and am not experiencing any issues with my Meraki devices. I’ve got the msg200 garage door opener, mss630 outdoor plug, and some light switches.