Help with ssh keys

need info on creating ssh keys and how to use them please
is the creation of ssh keys to allow me access to the aps

@regchan To create an ssh-key, you can use “ssh-keygen” from any Mac or Linux system. This will create an “id_rsa” and “id_rsa.pub” file in your home directory’s “.ssh” directory. All you need to do is copy and paste the contents of the “id_rsa.pub” file into our web UI, and then you should be able to ssh into the APs as the “root” user:

$ ssh root@192.168.1.50

BusyBox v1.33.1 (2021-10-24 09:01:35 UTC) built-in shell (ash)

4 Likes

finally logged in with SSH key
image

2 Likes

You’re a hacker now :slight_smile:

As I came across this post after reaching some failures, I wanted to at least share my experience.

At this time of this writing, it appears that ssh key is limited to a simple RSA keygen.

I tried using ed25519 but that failed.
I tried using rsa -b 4096 but that also failed.

I did not even tried to make a comment as part of the ssh keygen.

Using POP!_OS 22.04 LTS, I used the following commands:
ssh-keygen -t rsa -f id_rsa-ap6pro-simple-first

If you use an .ssh/config, you can add this entry:
Host appro6
Host appro6.mydomain.tls
User root
IdentityFile ~/.ssh/id_rsa-ap6pro-simple-first

hope this helps…

1 Like

i used putty gen to create my keyg gen files

PuTTY is the GUI ssh client.
PuTTYgen is the application that would generate keys.

TL;DR (on the above link), but I did a quick scan and saw that it was reference rsa.

ed25519 is a recommended because the public-key is smaller than RSA as well as being more secure.

Given that Alta is a newer company/hardware line, I was hoping other ssh keys could be used.

1 Like

I followed this 5 or 6 times now using MacOS and uploaded the contents of the pub file to your portal under SSH keys.

Whatever I do I get the error root@192.168.4.2: Permission denied (publickey)

Has something changed since this article or am I missing something obvious?

I managed to get this working in the end. Not quite as simple as this thread suggests because you have to specify your ssh key file in the ssh command when making the connection.