Getting Started Roadblocks


I got the invite email and read through the PDF (I have a few steps documented to getting LXC image working on proxmox which I will post to another thread). But I have the controller running, was able to use the activation code, but I get stuck here.
I see the activation success message, but the browser never forwards as described in step 5.

I can goto the controller local ip again and see login page. I tried creating an account, says to expect an email, but that email never shows up. I can confirm once I hit submit or resend email, the controller does reachout to a server:

Additionally I tried using the docker image, but the credentials int he PDF kept coming back as invalid from

Additionally I tried using the docker image, but the credentials int he PDF kept coming back as invalid from

The docker credentials is not ment to be used to login to, it can be used to download the image from command line, since it is only an access token limited to certain operations.

1 Like

Not sure i understand your reply.

docker login
Login with ****
c. docker pull altalabs/control-beta:1.0b

by default docker login will goto docker hub( the pull command fails if you cannot log in successfully that it requires auth.

root@HARDIN-SO-P-01:~# docker login
Log in with your Docker ID or email address to push and pull images from Docker Hub. If you don’t have a Docker ID, head over to to create one.
You can log in with your password or a Personal Access Token (PAT). Using a limited-scope PAT grants better security and is required for organizations using SSO. Learn more at Create and manage access tokens | Docker Docs

Username: ****
Password: ****
Error response from daemon: Get β€œ”: unauthorized: incorrect username or password

I executed the following command, and it worked:

docker login -u altajeff
Password: <the password from the PDF>

Login Succeeded
docker pull altalabs/control-beta:1.0b
1 Like

Ok, I pasted what I was copying to notepad for password, and looks like the font in pdf made it look like I had the entire thing, but the leading character wasnt actually carrying over. Thanks! I was able to get the image pulled on docker front.

Now to figure out the registration issue.

For me after the registration it also did not forward me to the local ddns page. What I did is opened once more the local IP, and there I was able to find the controllers ddns address

Ok I figured out the activation issue, turns out using alta control 1.0b fixes the issues I was running into.

Thanks again for the help on docker login issue @kengou