Attempting Local Controller via LXC and Docker. Unit will not adopt localled

My AP6-Pro is at version 2.0g.

I was able to get the container to work within a Proxmox environment with a few modifications.

I wanted to use proxmox because I have a production cluster (3 nodes) and I wanted to make sure the LXC will be running should any proxmox node has maintenance done.

Here is the web page

------ remove my commentary on what the contents of the controller. This could be something I share on a post later ----

There is a SSL certificate installed and you might need to create a local DNS record as the controller appeared to have a ddns name. I followed the type to add it to the local host but I also added to my main DNS source (pfSense appliance) for my network.

for example the controller is a subdomain of “

Is the new controller expected to have a hole in our network to allow this new ddns end point be routed back to the ip address of the new controller?

As I am not allow inbound requests (like an web app being hosted) to my environment due to rules/policies for the work I perform, I created two dns entries for the controller to work within my network. and

I did get the login screen with the DNS changes – and the connection is using SSL/TLS

The activation process did not lead to any password being set.

I did not realize that I had to create a user name/email address for this controller. Step 5 and 6.
After completing the “sign up” link, I was able to get an email notification for the new account.

emails are not sent from the local controller. It seems to be coming from Alta’s hosted platform on the internet. The account is stored locally on the control because I used a different email address than the initial account I created on Alta’s cloud.

I was able to setup the local controller and the details there.

it took me about 3 hours to get all this working on Proxmox.

The only part I have left is to have my unit switch over from the one on Alta’s cloud to my local controller.

I followed what @L3houx did.

  1. I removed the AP from and waited.
  2. I noticed after 2 minutes nothing was happening.
  3. After removing the ethernet plug and plugging it back in, the AP unit adopted back to the Alta’s cloud.
  4. I also removed my account on The AP unit did not connect to anything. When I re-created my account, the AP joined after I repeated step 3.

My assumption is that within the local network is needed for the unit to connect to the local controller.

I am logging all the network traffic this AP unit is doing within my network and with its outbound internet transactions.

I turned off the controller running via LXC.
I did the instructions to make the docker build. Everything went without any issues. I did change the root password to allow me to control it.

I was able to activate via the local controller web page. After the activation email, I was able to login and configure my site, etc.

I deleted my access point from the Alta cloud portal and it was added back to the cloud instance within a minute.