AP6 Pro in mesh mode is very slow compared to just having one access point


I have 2 access points set up. One is connected to the router and cable modem, the other is acting as a mesh node a couple rooms down in the office. I really have no easy way of stringing ethernet cable at the moment. There are 4 devices connected to the mesh node and around 20 connected to the main node, which consists of a few laptops and IOT devices.

If I connect my laptop from the office to main router several rooms down, I achieve a speed test of 140-210 down and 18-20 up.

If I turn on the mesh access point in the office and connect to it, I get 15-23 down and 15 up.

I understand that running in mesh mode is not ideal, but I did not expect performance to be ~10x worse compared to just running one node in the house.

Much thanks for any ideas or settings to try.

My initial thought is to use the Scan tool to make sure you’re using clear channels.

If you didn’t change any settings, you should still on the default channel width of 80MHz which, provided the internet connection is there, you should be doing speedtests of 500mbps+ so your non-meshed AP is substantially lower than it should be in terms of speeds.

Meshed APs must use the same 5GHz channel as its upstream so if you have interference at the wired AP, you will have that same interference on the meshed AP.

Thank you Matt.

Here are my findings this morning. I repeated my steps for both 40MHz and 80MHz (set on both units) and got roughly the same results. My testing device is an M1 Macbook Pro. There are roughly 25 IOT devices, mostly idle right now.

Just the main AP:

  • 375-400 near router
  • 175 in the hallway
  • 160 in the office
  • 160 in the office at same location as the secondary AP

Main AP + secondary mesh AP in the office, verified connected to second AP:

  • 18 near the secondary AP
  • 18 at desk

Here are some stats if this is helpful. Thanks!

Your 2.4GHz band is pretty congested. Your neighbor on channel 2 @ 40MHz channel width is taking up 2 of the 3 non-overlapping channels in 2.4GHz (1, 6, and 11) so your noise floor is going to be really high for your IoT devices.

Both of your APs are transmitting on the same 5GHz frequency, so you’re actually interfering with yourself. You also don’t have much spectrum available in that band due to your neighbors. I can’t see the results of the upper band. Generally speaking, avoiding DFS channels is a good target, but those are pretty much your only clear channels. DFS is channel 52-144.

You could try 165, but it could get difficult at 40MHz/80MHz. The 5GHz channels are 20MHz wide by default so if you use 40MHz, think of that as taking up 2 boxes, 80MHz 4 boxes. So I would try 165 and perhaps 60.

Thank you Matt!

Secondary shows 165/80 in the settings, and Primary shows 149/80.

However, all connected devices on secondary show 149. Also primary and secondary show 149 in the “network” tab.

I tried disconnecting the main AP and plugging the secondary into the ethernet and then everything showed up on 165. When I disconnected it, and plugged the primary back in, and the secondary as a mesh node, everything went back to 149. The settings still show 165, but connected devices to secondary show 149. Network speeds for 5g devices connected to secondary are < 20.

If I unplug the secondary and just connect to the main AP from the office, I’m now getting ~300 on 5g channel 149/80.

Ah, pardon me. I completely spaced on the mesh side of things.

Since the alternative is DFS, perhaps try channel 165 on the wired AP. The meshed AP will match shortly after.

What speed is your ISP?

Hi Matt,

Our internet service is Comcast, with “up to 800 down”, and 20 up.

If I run a speed test not long after I change the MHz from say, 80 to 40, or vice versa, then the performance goes up for a short while (80 down, 16 up). Subsequent tests will start to fall back down to around 20 down, no matter the configuration. I tried this multiple times and it seems to be pretty consistent. I’m not sure if this is a clue?

Chan 165, 80MHz, ~20 down.
Chan 165, 40MHz, ~63 down, 14.4 up (this was
Chan 165, 40MHz, ~16 down, 15 up
Chan 165, 20MHz, 65 down, 13.5 up
Chan 165, 80MHz, 58 down, 19 up
Chan 165, 80MHz, 6 down, 5 up
Chan 165, 80MHz, 22 down, 11 up

I did try two Aruba AP22s in the same configuration, and the Aruba managed around 160+ when connected to the mesh node, much better than the 20, but also much slower than the 300 of a single AP6.

Very well could be the noise on the channels below it, could also be a bit of self interference. Based on your screenshots, your APs may be too close together, showing -51. Let’s try the following:

  • Channel: 64 (wired AP)
  • Channel width 80MHz (wired AP)
  • Change the 5GHz TX Power setting to Medium (both APs)

Then, on the Network tab, let me know when you mouse over the mesh indicator what signal strength the meshed AP is seeing the wired AP at. Feel free to run speed tests while in this configuration. While DFS, that’s the only clean spectrum you have based on the scan results.

Additionally, running a speed test wired into the network would be helpful so we have a baseline of what you’re actually getting for speeds. 80MHz is overkill if 300 is the cap, but I suspect you’ll get higher wired speeds than that.

Good morning,

I just updated the settings. On medium Tx and channel 64, download is now ~24, and upload is 17 on the secondary node. Just the Primary node: 20.2/9.8. Moving back up to Auto Tx: 241/16.1.

Medium Tx, chan 64, connect to mesh node: 24 / 17
Medium Tx, chan 64, connect to primary node: 20 / 10
Auto Tx, chan 64, connect to primary node: 241 / 16

Medium Tx, chan 149, connect to mesh node: 22.6 / 14
Medium Tx, chan 149, connect to primary node: 34.6 / 14
Auto Tx, chan 149, connect to primary node: 278 / 20

Wired is 525 / 24.

If I place the Macbook exactly where the second node in the office and just connect to the Primary, just now I got 496 down, 24 up.

If I place the laptop 2’ from the primary node, 500 / 24.

I also noticed something different late last night. For a few devices it listed two channels, and two APs. For example, “1, 149” and “Primary, Secondary”. The node names would change ordering every couple of seconds.

The nodes are around 25 feet apart, through a hollow door, a closet, part of a dresser, and a couple of dry-walls. There are 27 devices, most of them connect to the Primary node.

Since the speeds are great at the position of the second node, and there are only around 5 IOT devices connected to it plus my laptop, is it possible that this could be a firmware issue? Happy to share diagnostic info if there’s a way. Firmware version is 2.0k.


That sounds like maybe you don’t even need the second AP. 25 feet with no big attenuation blockages. However, I can’t see what signal the mesh was linked at.

Could you go to the Network tab and let me know when you mouse over the mesh indicator what signal strength the meshed AP is seeing the wired AP at?

Correct, I probably don’t need one, but I do believe one will help with the bottom 1.5 floors on this side of the house. It would be two straight shots to my desk with the mesh node, otherwise there are probably an additional 2 walls plus closet between my desk and the router. The office is also in a good location to push signal through to the living room downstairs.

-50dB from the mesh node to main node.

I think you’d be best served moving that meshed AP further away. In a perfect world, you’d want that to be linked up to the primary at -60 to -65 signal. There is such a thing as having too good of a signal and the result is diminishing returns in most cases.

For the sake of speed testing, let’s not focus on that right now. It sounds like 165 @ 80MHz is decent, at least where the primary AP is located. I would suggest unplugging the meshed AP for now, and verify those speeds in different locations. Of course, they will vary a bit, but if you get to a location in the structure where you’re consistently getting slow speeds, we know that’s where you need more coverage. The key is to identify that location.

Good evening Matt.

The plot thickens!

So I found another post where someone was having a similar 20Mbps download speed on mesh, and one of the things towards the end that they tried was making an entirely new SSID, and then switching over to that new one. I created the new SSID, but without “WPA3” checked, and lo and behold, fast speeds. I then switched back over to one of my original SSIDs and I’m still getting the faster speeds. It may not be quite as fast as just the one node, but now the downstairs devices have better connections. So I do feel there’s a bug somewhere in there (memory corruption?), but am happy to have found a workaround.

If I wanted to try a manual Tx speed somewhere in between medium and high, what would you suggest? What would be the numbers for medium vs high? I imagine this would let the devices run a bit cooler.

Update: And just like that, I tinkered with a few settings and now I’m back down to the 20 Mbps rate. I changed the 5GHz channel from 149 to Auto for both nodes.