IPv6 not working with Alta AP's

Changed out some Omada EAP-225’s and couldn’t browse the internet properly on my iOS device (I’ve not tried anything else on the wireless yet).

Switching back to the Omada Ap’s and everything worked fine, as a test I disabled IPv6 on my wireless VLAN and then I was able to browse again whilst using the ALTA APs.

The VLAN for wireless devices is tagged (Shouldn’t make a difference but I know some people were having some vlan issues so…)

I’ll probably retest later with a non iOS device when I have some more time, but it seems the AP’s are doing something that’s breaking IPv6

Network type Standard and I tried the bypass filtering option bit it didn’t help.

1 Like

@dragon2611 Thank you for the report! I am using IPv6 here on Alta APs and it’s working great.
We haven’t been able to reproduce anything similar to what you’re describing here, so any more information about what router you use, how your VLANs are set up, etc. would be helpful. Even screen shots, videos, etc. showing what is failing might be more useful to help understand the problem.

Hi Jeff,

Router is a Firebrick FB2900 (Or at least the primary one is, there’s a secondary one for some IPv4 LAN > LAN traffic due to the Firebrick not being able to route at 1Gbit)

There’s a Trunk facing the AP (That I should probably remove some Vlans from as I think it has everything)
SSID is configured to use one of the VLAN’s at the moment i’m not using multiple PSK’s

I’ve tried setting the vlan in advanced and setting it against the PSK results are the same in both cases.

I’m sending further details into support.

Edit: I created a new Trunk facing the AP so it’s now only getting Vlans that are used for Wireless clients, although the problem still remains.

Right after testing various configurations I believe the problem occurs if the Vlan is being tagged by the AP (So either setting the VLAN for the PSK or in the advanced ssid options).

It seems If I’m on the Native (Management/Untagged) Vlan IPv6 works if I tag the the traffic to a different VLAN I get the address from the right range but I get the weird problem with pages not loading correctly (usually some .images not displaying).

check your settings it may be the privacy options on iphones wifi settings limit wifi tracking and err the apples relay thing

I turn those features off for my own network.

Also even if that was on it should still work, IPv6 with the ap tagging the vlan works fine on the TP-link EAPs it’s a fairly standard feature for any Enterprise AP.

It looks like there’s something werid going on with the Alta APs and vlans

@dragon2611 We’re happy to dig into the issue, but we are currently unable to reproduce any IPv6 issues in our internal testing. If you can provide more information on exactly how your VLANs and router are configured, and more details on what the exact symptoms are, that would help greatly.

I suspect (but can’t currently prove) that it’s related to the Vlan issues, there’s definitely something odd going on with Vlans

It very much sounds like something is a bit off with the Vlan filtering on the AP.

@dragon2611 Moving this to DM for the moment to try out a debug firmware with you…

Hi, Any chance you can test with the latest update on your APs when you get a chance?

1.0z has updates for VLANs and IPv6

Updated the AP’s, Initial feedback is everything looks ok but I’ve not tried browsing on Wi-Fi connected device much yet other than a quick test from my iphone.

I’ll likely know for sure by this evening once I finish work and are more likely to be streaming something to the TV or using a Wireless device to browse the internet.

1 Like